Маршрутизатор cisco

Как настроить маршрутизатор cisco / Организация сети для небольшого офиса

Как настроить маршрутизатор cisco / Организация сети для небольшого офиса

Как настроить маршрутизатор cisco

Всем привет сегодня хочу рассказать вам, как настроить маршрутизатор ciscoили организовать сеть для небольшого офиса. Поговорим об отличиях коммутатора 3 уровня и маршрутизатора, и разберем схему организации малого офиса и среднего, с использованием роутера Cisco. Думаю это интересная тема и весьма часто встречающаяся.

Напомню в предыдущей статье мы настроили коммутатор cisco в качестве ядра, работающего на 3 уровне модели OSI, и разобрали, что он производительнее и дешевле, чем router cisco. Так, что же тогда заставляет покупать маршрутизаторы Cisco, все дело в мозгах, которые дают функционал, такой как:

Без которого сложно представить как связывать удаленные офисы с центральным. Такая вот хитрая политика партии у Cisco.

Схема филиала такая: 1 роутер Router0 модели Cisco 1841 для примера, один коммутатор Cisco 2960 и три компьютера. Как видите у нас есть 3 сегмента, для которых мы настроим vlan. Предполагается, что у вас уже произведена базовая настройка коммутатора Cisco.

Создаем VLAN2, VLAN3, VLAN4. Логинимся на ваш cisco 2960 и переходим в режим конфигурирования/

теперь определим каждый компьютер в нужный vlan. PC0 в vlan 2, PC1 в vlan 3, PC2 в vlan 4. У меня это порты fa0/1, fa0/2 и fa0/3.

switchport mode access

switchport access vlan 2

switchport mode access

switchport access vlan 3

switchport mode access

switchport access vlan 4

Следующим шагом будет настроить trunk порт до нашего роутера Cisco 1841. Вводим следующие команды

Выбираем нужный интерфейс

Выставляем режим trunk

разрешаем определенные vlan

Все работы на коммутаторе Cisco 2960 закончены, переходим к нашему роутеру.

Начнем настраивать маршрутизатор cisco 1841, для того чтобы он маршрутизировал трафик между vlan и был в качестве интернет шлюза. По умолчанию все порты на маршрутизаторе находятся в выключенном состоянии, включим порт куда воткнут патчкорд от коммутатора cisco 2960, у меня это fa 0/0.

У вас появится нечто подобное, сообщая вам что порт стал быть активным.

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Порт стал зеленым

Следующим шагом нужно создать сабъинтерфейсы по количеству vlan. У роутеров просто нет vlan и их роль выполняют сабъинтерфейсы, где определенному vlan соответствует subinerface.

Создаем subinterface для vlan 2

указываем что он относится и случает пакеты vlan 2

настраиваем ip адрес

и сохраняем настройки командой

Настроим подобный образом subinterface для vlan 3,4

encapsulation dot1Q 3

ip address 192.168.2.251 255.255.255.0

encapsulation dot1Q 4

ip address 192.168.3.251 255.255.255.0

Пробуем пропинговать с компьютера PC0 компьютер PC3 и PC2. Как видим на скриншоте все ок.

Вот так вот просто организовать локальную сеть в очень небольшом филиале и где быстро производится настройка маршрутизатора cisco. настройку NAT мы произведем в другой статье.

Вот как выглядит схема локальной сети среднего офиса. Есть маршрутизатор cisco 2911, выступающий в роли интернет шлюза. Есть ядро сети коммутатор 3 уровня Cisco 3560. Он будет маршрутизировать локальный трафик между vlan сети. В Cisco 3560 воткнуты 3 коммутатора второго уровня Cisco 2960, которые уже подключают в себя конечные устройства. В сети есть 3 vlan 2,3,4.

Начнем с настройки Switch1, сегмента серверов. Логинимся в режим глобальной конфигурации.

Закинем порты fa 0/1-2 в VLAN4

switchport mode access

switchport access vlan 4

Настроим trunk порт fa 0/3, разрешать будем только трафик vlan4

switchport mode trunk

switchport trunk allowed vlan 4

Все с сегментом серверов мы закончили. Переходим к такой же настройке на Switch2 и 3. И так Switch2 Cisco 2960.

Первым делом создаем vlan 2 и vlan3.

Теперь определим наши порты в которые подключены компьютеры в нужные vlan

switchport mode access

switchport access vlan 2

switchport access vlan 3

Настроим trunk порт на интерфейсе fa 0/3

switchport mode trunk

switchport trunk allowed vlan 2,3,4

Тот же фокус проводим с настройкой Switch3 Cisco 2960

Первым делом создаем vlan 2 и vlan3.

Теперь определим наши порты в которые подключены компьютеры в нужные vlan

switchport mode access

switchport access vlan 2

switchport access vlan 3

Настроим trunk порт на интерфейсе fa 0/3

switchport mode trunk

switchport trunk allowed vlan 2,3,4

Приступаем к настройке маршрутизации, на ядре Cisco 3560, все три его порта нужно настроить как trunk, создать vlan и назначить им ip.

создаем vlan 2,3,4

Задаем статический ip адрес vlan2,3,4

ip address 192.168.1.251 255.255.255.0

ip address 192.168.2.251 255.255.255.0

ip address 192.168.3.251 255.255.255.0

Настраиваем trunk порты

switchport trunk encapsulation dot1q

switchport mode trunk

switchport trunk allowed vlan 2,3

switchport trunk encapsulation dot1q

switchport mode trunk

switchport trunk allowed vlan 2,3

switchport trunk encapsulation dot1q

switchport mode trunk

switchport trunk allowed vlan 2,3

Включаем маршрутизацию и сохраняем конфигурацию

Ping будет производиться с компьютера PC3. Как видим, сервера и обычные компьютеры разделены.

О настройке интернета и NAT поговорим в следующих статьях на данную тему. Как видите конфигурирование маршрутизаторов cisco, не такое уж и сложное дело.

5 Responses to Как настроить маршрутизатор cisco / Организация сети для небольшого офиса

Здравствуйте. Мне нужно наоборот разграничить сеть. Есть небольшой офис, в нем на циске 890 настроено несколько влан-ов. И нужно сделать так, чтоб они не видели друг друга. Через ACL никак не получается у меня настроить

А можете нарисовать схему сети вашей в cisco packet tracer?

ПК получают адреса 30.2 и 50.2 Нужно, чтоб 192.168.30.2 не видел 192.168.50.2, но оба видели 192.168.0.1

Привет. Меня тоже интересует етот вопро. Спасибо.

Маршрутизаторы Cisco

Производитель — Cisco; Артикул — SPA3102-EU; Web-интерфейс — есть;

  • Производитель — Cisco; Артикул — WRP400-G2; Демилитаризованная зона (DMZ) — есть;

  • Производитель — Cisco; Артикул — CISCO1801; DHCP-сервер — Да; NAT — есть; Межсетевой экран (FireWall) — есть; Поддержка IPv6 — Да;

  • Производитель — Cisco; Артикул — CISCO881-K9; DHCP-сервер — Да; NAT — есть; Межсетевой экран (FireWall) — есть; Поддержка Telnet — есть;

  • Производитель — Cisco; Артикул — CISCO2801; DHCP-сервер — Да; NAT — есть; Межсетевой экран (FireWall) — есть;

  • Производитель — Cisco; Артикул — CISCO892-K9; DHCP-сервер — Да; NAT — есть; Межсетевой экран (FireWall) — есть; Поддержка IPv6 — Да; Поддержка Telnet — есть;

  • Производитель — Cisco; Артикул — CISCO2821; DHCP-сервер — Да; NAT — есть; Межсетевой экран (FireWall) — есть;

    Интернет-магазин AMELTA предлагает широкий ассортимент компьютерного и сетевого оборудования. Мы поможем вам приобрести недорогие устройства с отличным качеством.

    В нашем каталоге вы можете найти маршрутизаторы Cisco, цена которых колеблется от 3 000 до 128 000 рублей. Такие показатели зависят от определенных параметров, специальных функций, а также дизайна и вида самого оборудования. Маршрутизатор Cisco – это отличное решения для тех, кто хочет создать небольшую локальную сеть.

    Это оборудование станет идеальным решением ваших проблем, связанных с разворачивание LAN-сети. Наши специалисты помогут определиться с выбором каждому, кому понадобится помощь. В интернет-магазине AMELTA действует бесплатная курьерская доставка по городу Екатеринбург и доставка любой транспортной компанией по всей России.

    Спешим обрадовать наших покупателей появлением на сайте большого числа новых моделей маршрутизаторов Linksys и Huawei.

    Советы по выбору коммутатора или маршрутизатора Cisco

    Для развёртывания масштабируемых сетей необходимо иметь базовое представление о сетевом оборудовании Cisco. Большинство моделей хорошо масштабируются вместе с сетью в процессе её увеличения. Поэтому у компании имеются различные серии маршрутизаторов, коммутаторов и прочего оборудования для обеспечения современной архитектуры сети и её требований.

    Очень важно выбрать подходящее для текущих требований сети оборудование во время её проектировки с запасом производительности для дальнейшего её роста. Коммутаторы и маршрутизаторы играют критическую роль, особенно в среде предприятия. Поэтому в этой статье мы рассмотрим некоторые из главных критериев, которые помогут правильно выбрать оборудование Cisco для вашей сети (главным образом для корпоративной)

    Есть пять категорий коммутаторов для корпоративных сетей

    Коммутаторы для кампусных сетей (Campus LAN Switches): Для обеспечения масштабируемости сетевой производительности существуют коммутаторы уровня ядра, распределения, доступа, а также компактные коммутаторы. Разнообразие этих платформ варьируется от простых коммутаторов без кулера с восемью фиксированными портами до блейд-коммутаторов, состоящих из 13 лезвий, поддерживающих сотни портов. Коммутаторы для кампусных сетей включают в себя серии Cisco 2960, 3560, 3750, 3850, 4500, 6500 и 6800.

    Коммутаторы с облачным управлением (CloudManaged Switches): Коммутаторы доступа с облачным управлением Cisco Meraki позволяют использовать виртуальное стекирование. Они отслеживают и конфигурируют тысячи портов коммутатора по сети без привлечения персонала IT.

    Коммутаторы для ЦОД (Data Center Switches): Центр обработки данных должен быть построен из коммутаторов, которые обеспечивают масштабируемость инфраструктуры, непрерывное функционирование и гибкость транспорта данных. Коммутаторы для ЦОД включают в себя серии Cisco Nexus и Cisco Catalyst 6500.

    Коммутаторы для поставщиков услуг (Service Provider Switches): Коммутаторы для поставщиков услуг подразделяются на две категории: коммутаторы агрегации и коммутаторы доступа к Ethernet. Коммутаторы агрегации — это Ethernet-свитчи операторского класса, которые агрегируют трафик на границе сети. Коммутаторы доступа к Ethernet включают в себя контроль данных на прикладном уровне, объединённые сервисы, виртуализацию, встроенную безопасность и облегчённое управление.

    Виртуальные сети (Virtual Networking): Сети становятся преимущественно виртуализированными. Виртуальные коммутаторы Cisco Nexus обеспечивают безопасные мультиарендные сервисы путём добавления технологии интеллектуальной виртуализации в сеть ЦОД.

    Сетевые администраторы должны определить форм-фактор коммутаторов при выборе. Коммутаторы бывают фиксированной конфигурации, модульной, стековой и нестековой.

    Коммутаторы фиксированной конфигурации

    Коммутаторы модульной конфигурации

    Коммутаторы стековой конфигурации

    Высота свитча, выраженная в юнитах, также важна при монтировании в стойку. Например, коммутаторы фиксированной конфигурации, показанные на изображении выше, все являются одноюнитовыми.

    Помимо этих замечаний также стоит обратить внимание на следующие особенности при выборе коммутаторов:

    Плотность портов свитча характеризуется количеством портов на одно устройство. Изображения ниже показывают три свитча с разной плотностью портов.

    Коммутаторы фиксированной конфигурации обычно поддерживают до 48 портов на одно устройство. Также есть возможность установить в такие коммутаторы дополнительно до четырёх портов для устройств small formfactor pluggable (SFP). Высокая плотность портов позволяет лучше использовать ограниченное пространство и питание. Два 24-портовых свитча смогут поддерживать только 46 устройств, потому что, как минимум, один из портов каждого свитча необходим для его соединения с аплинком. Также необходимы две розетки. А если у вас есть один 48-портовый свитч, вы можете подключить до 47 устройств, так как нужен будет только один порт для соединения с аплинком и только одна розетка.

    Свитчи модульной конфигурации обеспечивают очень высокую плотность портов путем добавления дополнительных карт расширения. Например, некоторые коммутаторы Catalyst 6500 поддерживают более 1000 портов.

    В больших корпоративных сетях, к которым подключаются тысячи устройств, лучше использовать модульные свитчи с высокой плотностью портов, чтобы более рационально использовать пространство и питание. В противном случае вам потребуется множество коммутаторов с фиксированной конфигурацией. Такое решение потребует большое количество розеток и много свободного места.

    Проектировщик сети также должен принимать во внимание проблему «узкого горлышка» аплинка: группа свитчей с фиксированной конфигурацией занимает множество дополнительных портов для агрегации полосы пропускания между свитчами для того, чтобы достигнуть необходимой производительности. С одним модульным свитчем агрегация полосы пропускания является не такой серьезной проблемой, так как плата межсоединений способна обеспечить необходимой полосой пропускания устройства, подключённые к карте расширения портов.

    Скорость коммутации – это значение, определяющее скорость обработки информации свитчем за одну секунду. Линейки коммутаторов классифицируются по скорости коммутации.

    Свитчи начального уровня имеют скорость коммутации гораздо ниже, чем свитчи корпоративного класса. Скорость коммутации является очень важным показателем при выборе свитча. Если скорость коммутации слишком маленькая, то свитч не сможет обеспечить полную пропускную способность всех его портов. Физическая скорость — это показатель теоретически возможной максимальной скорости работы каждого Ethernet-порта коммутатора. Значения физической скорости могут быть такими: 100 Мбит/сек, 1 Гбит/сек, 10 Гбит/сек или 100 Гб/сек.

    Например, типичный 48-портовый гигабитный свитч, функционирующий при полной физической скорости, способен генерировать 48 Гбит трафика в секунду. Но если свитч поддерживает скорость коммутации только 32 Гбит/сек, то все его порты одновременно не смогут работать при полной физической скорости. Однако, свитчи уровня доступа обычно не нуждаются в полной скорости, потому что они физически ограничены аплинком. Это означает, что менее дорогие и менее производительные свитчи могут быть использованы на уровне доступа, а более дорогие высокопроизводительные лучше использовать на уровнях распределения и ядра сети, где от скорости коммутации очень сильно зависит производительность всей системы.

    Технология Power over Ethernet (PoE) позволяет коммутатору подавать питание на устройство по кабелю Ethernet. Эта функция обычно используется некоторыми IP-телефонами и беспроводными точками доступа.

    РоЕ предоставляет большую гибкость при установке точек доступа и IP-телефонов. С этой технологией их можно установить везде, где есть Ethernet-кабель. Сетевой администратор должен быть уверен, что технология РоЕ необходима, т.к. свитчи, поддерживающие эту технологию, стоят значительно дороже.

    Относительно новые серии коммутаторов Cisco Catalyst 2960-C и 3560-C поддерживают проброс РоЕ

    Проброс РоЕ позволяет сетевому администратору подавать питание на РоЕ-устройства, подключенные к свитчу, и на сам свитч от вышестоящих коммутаторов.

    Многоуровневые коммутаторы обычно используются на уровнях ядра и распределения сети. Особенностью многоуровневых свитчей является возможность построения таблицы маршрутизации, поддержка нескольких протоколов маршрутизации и коммутации IP-пакетов со скоростью, близкой к коммутации 2-го уровня. Многоуровневые коммутаторы обычно поддерживают специализированное оборудование такое, как ASIC (ApplicationSpecific Integrated Circuit, интегральная схема специального назначения). ASIC вместе с выделенными структурами программных данных могут выполнять коммутацию IP-пакетов без использования ЦП.

    В последнее время стала очень популярна тенденция к чистой маршрутизации 3-го уровня с помощью коммутаторов. Когда коммутаторы впервые использовались в сетях, ни один из них не поддерживал маршрутизацию. Сейчас же почти все поддерживают. Скорее всего, скоро все свитчи будут включать в себя процессор маршрутизации, потому что стоимость такого свитча постепенно уменьшается. В конечном счёте, термин многоуровневый коммутатор станет неактуальным.

    Коммутатор Catalyst 2960 наглядно показывает миграцию в среду 3го уровня.

    Так же, как и коммутаторы, маршрутизаторы выполняют важную функцию на уровнях доступа, распределения и ядра сети. Во многих малых сетях (таких, как сети филиалов) все 3 уровня выполняются на маршрутизаторе.

    В корпоративной сети на уровне распределения необходима маршрутизация. Без процесса маршрутизации пакеты не смогут попасть во внешнюю сеть.

    Маршрутизаторы играют важную роль в сетевых технологиях, соединяя между собой различные объекты внутри корпоративной сети, предоставляя резервные маршруты и обеспечивая взаимодействие провайдеров в Интернете. Роутеры также могут выступать в роли преобразователей между различными носителями и протоколами, например можно принимать пакеты из сети Ethernet и переинкапсулировать их для передачи в последовательную сеть.

    Маршрутизаторы используют целевые IP-адреса для доставки пакетов к соответствующему месту назначения. Роутеры меняют маршрут на альтернативный, если пропадает сетевое соединение или возрастает нагрузка трафика. Все устройства локальной сети имеют назначенный IP-адрес маршрутизатора в своей сетевой конфигурации. Интерфейс роутера является шлюзом по умолчанию.

    Маршрутизаторы также выполняют и другие важные функции:

    — ограничивают широковещательный трафик в ЛВС

    — связывают между собой географически удалённые локации

    логически группируют пользователей, которым нужны одни и те же сервисы

    Для предприятий и провайдеров услуг эффективная маршрутизация и быстрейшее восстановление после сбоев имеет огромное значение.

    Сетевым администраторам в среде предприятия нужно иметь возможность поддерживать множество различных роутеров, начиная с малых настольных и заканчивая стоечными блейд-маршрутизаторами. Одним из маршрутизаторов Cisco на рынке сегодня является роутер серии Cisco ISR G2. Как правильно выбрать маршрутизатор Cisco? По данной ссылке вы можете получить больше информации о выборе роутера Cisco ISR G2 Series для вашей сети.

    Интеграция сетевых технологий и обеспечения информационной безопасности.

    Источники:
    Маршрутизатор cisco 1
    как настроить маршрутизатор cisco. Поговорим об отличиях коммутатора 3 уровня и маршрутизатора, и разберем схему организации малого офиса и среднего, с
    http://pyatilistnik.org/kak-nastroit-marshrutizator-cisco-organizatsiya-seti-dlya-nebolshogo-ofisa/
    Маршрутизаторы Cisco
    В интернет-магазине AMELTA.RU маршрутизаторы cisco имеются в наличие большой ассоритмент различных моделей по самым привлекательным и низким ценам. Купить маршрутизаторы cisco всегда можно у нас с бесплатной доставкой по городу
    http://amelta.ru/catalog/marshrutizatory/cisco
    Советы по выбору коммутатора или маршрутизатора Cisco
    Советы по выбору коммутатора или маршрутизатора Cisco
    http://stornet.ru/articles/sovety_po_vyboru_kommutatora_ili_marshrutizatora_cisco/

  • COMMENTS